Degraded performance due to Google Maps API issue

Incident Report for PropertyLens

Postmortem

See https://status.cloud.google.com/maps-platform/incidents/8KmM6cYopmd6ByrxfRBR. Our users experienced degraded performance where fire station distance and drive time may have been omitted for a total of eight requests to our property profile endpoint. All other data would have returned normally.

As this incident was out of our control but affected a critical field in our API response, we chose to alert end-users as to possible data quality issues. No further action will be taken on this incident.

Posted Mar 11, 2026 - 15:26 UTC

Resolved

Google reports the issue is resolved as of 10:15 ET.
Posted Mar 11, 2026 - 15:23 UTC

Investigating

We are currently having intermittent performance issues due to a Google Maps API outage. https://status.cloud.google.com/maps-platform/
Posted Mar 11, 2026 - 14:01 UTC
This incident affected: Data APIs (Property Profile, Property Insights).