Degraded performance for Property Characteristics

Incident Report for PropertyLens

Resolved

Our upstream data provider has informed us their systems reliability has been restored and we are observing improved response times and hit rates.
Posted May 13, 2026 - 18:01 UTC

Identified

The issue was identified shortly after the incident started. However, we are still awaiting a fix from our upstream data provider.
Posted May 13, 2026 - 16:09 UTC

Investigating

We are currently investigating this issue. Customers may experience slow responses or timeouts during this period.
Posted May 13, 2026 - 14:27 UTC
This incident affected: Data APIs (Property Profile, Property Characteristics).